Wrong port?

Andreas Brunsmann shared this problem 20 months ago
Cannot Reproduce

I got problems connecting to a local mongo db instance after the succesfull login via ssh. The details show that a different port ist used than defined in the settings.

884a2ef746812150feef99eea2eb44ab


If i click on "To URI" i can use the generated string on the shell without any problems to log the user in. In this string the port is right. What am i doing wrong. Same settings work in Robo 3T too.

87ec5cee42c272c88ec49e4f76a5f9e0

Comments (5)

photo
1

Only from the error description, I can not locate the problem, can you give me a complete reproduction step.

photo
1

I set my credentials for SSH (private key file, passphrase, user) and than inserted my credentials in the "Authentication" tab. In the "Basic" tab it says 27017 for port. When i hit "To URI" it uses this port. When i hit "test connection" it seems to use another random generated (?) port.

92c4bb106f07c5e4bdbb4c742b698f5a

12bd4bb823f27b60039c5259294c2941

photo
1

UPDATE: I created another entry in the connections list without a "mark with color" setting and name is still "localhost". That one works:


943d592f9b392ede9cbbbe85dc344847

photo
1

Thanks.


I tried to create an SSH connection that was the same as your configuration, the same name "IFU2 | BDB", the same " Mark with Color ", but still can't reproduce the problem

photo
1

I just exported my connections and send it to you by mail. By checking the json file i noticed that i referenced a public key file not PKK in the first connection ;-)

That explains why it wont work - but why does the test connection-funcion mark this as OK?


Anyway - thx for your help!