kill operation in monitoring not allowed...

Thingsplay shared this problem 2 months ago
Solved

I don't see the button "kill operation" when I'm in monitoring mode ? what can i do ?

Comments (7)

photo
1

It is possible that it is not displayed just because there is not enough space. Try maximizing the window.

photo
1

9ff9bc025dcdb3e5e5349d0a12950ca5

photo
1

Can you check that all the data returned has the following fields ['host', 'desc','active','opid']? If any field is missing, the button will be invisible. It could be a flaw, and we'll fix it in the next version.

photo
1

I don't see " host " what can i do ? . It's for this functionality I bought your software.

photo
1

I don't know why there's no ”host" field. Any special settings for your MongoDB server? What version?

Here is a work-around solution to add host field if it does not exists. Please paste the following code.

var ops = db.currentOp({
active: true,
//waitingForLock : true,
//secs_running : { $gt : 3 }, //longer than 3 seconds
//$ownOps:true //returns information on the current user’s operations only.
//$all:true, //including operations on idle connections and system operations
//ns : /^db\.collection/
});

(ops.inprog || ops).map(it=>{return {host:"none", ...it}}) 

photo
1

Thanks it work!!

photo
1

Resolved in 5.2.1