Is it possible to control the size of the Mongo Booster command history?

Amnon Khen shared this question 3 years ago
Answered

I would like to increase the size of the command history maintained by MongoBooster.

Is it possible?

Where is it maintained?

Comments (9)

photo
1

It is impossible to increase the size of the command history. The max size of the command history is fixed, it is 30.

photo
1

Thanks for the answer.

Why is it so.

For me it would be useful to have a larger history size. Sometimes I need a query I ran sometime in the past, and it would be nice if Mongo booster made my past queries available.

I have a configurable history in other db clients, as well as my shell interpreter and my browser. Why not my beloved Mongo client?

photo
1

I would like this feature too.

Very often I want to re-execute a query I did the previous day (which I did not intend to save at that time), and its already gone...

photo
1

In the Version 4.5.x, the max size of the command history has been increased to 1024, the quota size of storage is 10M. But the UI has a bug that can really cause some historical scripts to be lost, we have worked a build to fix the bug, please download and give it a try.

The following build is not a formal release, just for test-purpose.Please download and give a try.

Linux: https://nosqlbooster.com/s3/download/releasesv4/nosqlbooster4mongo-4.5.1.AppImage

Mac: https://nosqlbooster.com/s3/download/releasesv4/nosqlbooster4mongo-4.5.1.dmg

Windows: https://nosqlbooster.com/s3/download/releasesv4/nosqlbooster4mongo-4.5.1.exe

photo
1

I use version 3.5.5. Can we have a fix for v3 please?

photo
1

In version 3.x. The max size of the command history is fixed to 30, can not be changed. The UI for history scripts is very different from V4. We have no plan to fix it for V3.x.

photo
1

For some reason, I don't see more than 2. I remember seeing up to 30 in the past with free edition. After buying the license and upgrading, I am limited to just 2. Can someone help me figure out whats going on? I even tried the new version 4.5.1 and its the same story.

photo
1

Menu -> Help -> Open User Data Directory

Backup and remove .\Local Storage directory and try it again.

photo
1

I tried multiple ways to clear the local storage directory but it doesn't work. Again on Mac I don't see the option of "Open User Data Directory". Is there any other way to increase the history size. It's literally fixed at 3. It would help if we have at least 1000.

photo
1

Which version are you using?

We just uploaded version 4.3.2 which uses IndexedDB instead of local storage to store history scripts. Could you please download and give a try.

https://nosqlbooster.com/downloads

photo